CftClub.ru
Клуб специалистов ЦФТ-Банк

15.5
На страницу 1, 2, 3, 4, 5  След.
 
Ответить на тему    Клуб специалистов ЦФТ-Банк (IBSO) -> Обновления и тестирование
Предыдущая тема :: Следующая тема  
Автор Сообщение
yaffil
Профи
Неподтвержденный


Вступление в Клуб: 18.08.2011
СообщениеПн Окт 12, 2015 17:44   15.5 Ответить с цитатой
Полезность: Нет оценки
Прыгаю с 15.3 поставил сразу Т.Я. 7.4.4.2, но в 15.4 огран на <7.4.3, я его тупо снял. Не охото Т.Я. 2 раза ставить т.к. по 200 объектов руками приходится выискивать и компилить после каждого ТЯ. Через опу всё ЦФТ.
На что может повлиять? Я так понимаю то что сломается - вылечится на 15.5 и ничего страшного не будет?
Или будет Confused
nobel
Участник - экстремал
Неподтвержденный


Вступление в Клуб: 28.09.2011
СообщениеПн Окт 12, 2015 18:01   Re: 15.5 Ответить с цитатой
Полезность: Нет оценки
yaffil пишет:
Прыгаю с 15.3 поставил сразу Т.Я. 7.4.4.2, но в 15.4 огран на <7.4.3, я его тупо снял. Не охото Т.Я. 2 раза ставить т.к. по 200 объектов руками приходится выискивать и компилить после каждого ТЯ. Через опу всё ЦФТ.
На что может повлиять? Я так понимаю то что сломается - вылечится на 15.5 и ничего страшного не будет?
Или будет Confused


у нас была проблема на какой то версии 15.X.поставили ТЯ от будущей версии и нужна пару пакетов так и не откомпилилось.написали в ЦФТ и посоветовали ставить ТЯ которое пишется в документации к версии.
насчет вашего случая то конечно пробовать на тесте и смотреть что да как.самый плохой вариант-сломается "важный" пакет который на другие пакеты появлияет и невозможно будет установить до конца обновление 15.4(например провести этап конвертации данных).
еще проблема может быть это время установки двух версий сразу(полностью с дополнениями,конвертациями и прочим)

у нас при переходе на тесте на 15.5 процесс застопорился конвертация данных для недействительных паспортов(92 млн записей update).Многопоточность ЦФТ в этом плане не работает и уходит в undo.Делали в ручную(скрип писали на пл+) и процесс занял 9 часов где то.
svn
Профи
<Банки (менее 3 участников)>


Вступление в Клуб: 04.02.2008
СообщениеПн Окт 12, 2015 18:39    Ответить с цитатой
Полезность: Нет оценки
я так понимаю в 7.4.4.3 они откатили неткорые изменения из 7.4.4.2 - так что рекомендую сразу на последний патч
а также внимательно ставить MDB из ТЯ
mike24
Участник со стажем
Неподтвержденный


Вступление в Клуб: 24.08.2012
СообщениеВт Окт 13, 2015 04:23    Ответить с цитатой
Полезность: Нет оценки
Задал вопрос ЦФТ:
"Сейчас банк работает на версии 15.3, ТЯ 7.4.2.3. Планируем переход на 15.5. Возможно ли обновить ТЯ с 7.4.2.3 сразу до 7.4.4.2 и затем последовательно ставить ПЯ 15.4 и 15.5?"
Получил ответ :
Подобный переход рекомендовать не можем, так как такой переход не тестировался и какие могут возникнуть ситуации не известно.
Но с большой вероятностью все должно работать корректно.
Поэтому предлагаю провести подобный переход на тестовой схеме, убедиться, что не возникает ошибок и только после этого переходить на боевой.

Алексей, попробуй, вроде бы должно получиться. Только ставить надо сразу 7443. как писали выше.
mike24
Участник со стажем
Неподтвержденный


Вступление в Клуб: 24.08.2012
СообщениеВт Окт 13, 2015 04:45   Re: 15.5 Ответить с цитатой
Полезность: Нет оценки
nobel пишет:

еще проблема может быть это время установки двух версий сразу(полностью с дополнениями,конвертациями и прочим)

Зачем дополнения на промежуточной версии? При переходе с 15,3 ставим 15,4 без дополнений, затем 15,5
Или я что-то пропустил? Smile
nobel
Участник - экстремал
Неподтвержденный


Вступление в Клуб: 28.09.2011
СообщениеВт Окт 13, 2015 07:57   Re: 15.5 Ответить с цитатой
Полезность: Нет оценки
mike24 пишет:
nobel пишет:

еще проблема может быть это время установки двух версий сразу(полностью с дополнениями,конвертациями и прочим)

Зачем дополнения на промежуточной версии? При переходе с 15,3 ставим 15,4 без дополнений, затем 15,5
Или я что-то пропустил? Smile


цфт рекомендует ставить в порядке выпуска-сначала сама версия,потом по порядку дополнения,потом снова версия и к ней все дополнения.

порой фиг знаешь что цфт сделает в новой версии.могут и не включить в новой версии что включали в дополнении.за 5 лет работы с цфт в плане обновлений/дополнений все что угодно можно ожидать
mike24
Участник со стажем
Неподтвержденный


Вступление в Клуб: 24.08.2012
СообщениеВт Окт 13, 2015 08:31   Re: 15.5 Ответить с цитатой
Полезность: Нет оценки
nobel пишет:

цфт рекомендует ставить в порядке выпуска-сначала сама версия,потом по порядку дополнения,потом снова версия и к ней все дополнения.

Таких рекомендаций не встречал, дайте пож-та посмотреть, если они есть у Вас. Всегда считал, что функционал дополнений, выпущенных к версии 15,4 например, включается в версию 15,5 по определению. Да и сам неоднократно накатывал несколько версий подряд без установки промежуточных дополнений.
Может быть уважаемые сотрудники ЦФТ. читающие форум, нас рассудят?
yaffil
Профи
Неподтвержденный


Вступление в Клуб: 18.08.2011
СообщениеВт Окт 13, 2015 08:57    Ответить с цитатой
Полезность: Нет оценки
mike24 пишет:
Алексей, попробуй, вроде бы должно получиться. Только ставить надо сразу 7443. как писали выше.


Попробовал - получил. Пошел Катать ТЯ по порядку Laughing

Ошибка, 20300, При запуске тела операции произошла ошибка (SQL-exception):
ORA-20300: APP-CONV.MLIB: Ошибка при исполнении кода через динамический PL/PLUS:
Ошибка исполнения задания "15.4_059. Депозиты. Конвертация данных справочников 1417-У 3/4" : Поставлено в очередь 12/10/2015 22:08:24.
1. 12/10/2015 22:08:55.ORA-00060: взаимная блокировка при ожидании ресурса
yaffil
Профи
Неподтвержденный


Вступление в Клуб: 18.08.2011
СообщениеВт Окт 13, 2015 09:06    Ответить с цитатой
Полезность: Нет оценки
Не не пошёл. Нажал попробовать повторно - 10 пункт выполнился. Чёже так все через опу, обновление само себя блокирует.
mike24
Участник со стажем
Неподтвержденный


Вступление в Клуб: 24.08.2012
СообщениеВт Окт 13, 2015 09:41    Ответить с цитатой
Полезность: Нет оценки
yaffil пишет:
Не не пошёл. Нажал попробовать повторно - 10 пункт выполнился. Чёже так все через опу, обновление само себя блокирует.

ну это не баг, это фича Smile
Pupil
Участник - экстремал
Неподтвержденный


Вступление в Клуб: 27.02.2014
СообщениеВт Окт 13, 2015 10:55    Ответить с цитатой
Полезность: Нет оценки
Гламурная фича глючит)))
yaffil
Профи
Неподтвержденный


Вступление в Клуб: 18.08.2011
СообщениеВт Окт 13, 2015 13:14    Ответить с цитатой
Полезность: Нет оценки
Пока всё плохо - криво встала обнова 15.4 на Т.Я. 7.4.4.2 (да и Т.Я. само не красиво встало - появилось много невалидов, хотя ручками они и откомпилились через Админ словаря, групповая не помогла, надо именно встать на невалид и нажать F9 )
Пошел ставить по попрядку узнаю где проблем, по крайней мере Т.Я. 7.4.2.6 ничего не сломало - запустил 15.4
nobel
Участник - экстремал
Неподтвержденный


Вступление в Клуб: 28.09.2011
СообщениеСр Окт 14, 2015 08:41    Ответить с цитатой
Полезность: Нет оценки
yaffil пишет:
Пока всё плохо - криво встала обнова 15.4 на Т.Я. 7.4.4.2 (да и Т.Я. само не красиво встало - появилось много невалидов, хотя ручками они и откомпилились через Админ словаря, групповая не помогла, надо именно встать на невалид и нажать F9 )
Пошел ставить по попрядку узнаю где проблем, по крайней мере Т.Я. 7.4.2.6 ничего не сломало - запустил 15.4

я после обновление ТЯ только описание и мдб ставлю и проверяю на инвалидность сами пакеты а не операции.операции починятся после перекомпиляции всей схемы(скрипт run_scripts_ms.bat) при обновлении ИБСО.
Если так критично чтобы все операции корректны были после обновлении ТЯ то можно этот же скрипт и запустить run_scripts_ms.bat(если так много их и лень ручками компилить)
mike24
Участник со стажем
Неподтвержденный


Вступление в Клуб: 24.08.2012
СообщениеЧт Окт 15, 2015 13:18    Ответить с цитатой
Полезность: Нет оценки
Было: ТЯ 7423, версия 15,3. Установил ТЯ 7443, установил 15,4 без дополнений, установил 15,5. Инвалидов нет. Работает Smile
yaffil
Профи
Неподтвержденный


Вступление в Клуб: 18.08.2011
СообщениеЧт Окт 15, 2015 13:45    Ответить с цитатой
Полезность: Нет оценки
mike24 пишет:
Было: ТЯ 7423, версия 15,3. Установил ТЯ 7443, установил 15,4 без дополнений, установил 15,5. Инвалидов нет. Работает Smile


Инвалиды лечатся в 15.4.01 и соответственно в 15.5 - Вот так ЦФТ через ОПУ выпускают версии.
Была проблема с пеерсечением? Я поставил 15.4 на правильное Т.Я. - ошибка та же в том же месте. Делаю в 4 потока. ЦФТ говорит - забить.
Показать сообщения:   
Ответить на тему    Клуб специалистов ЦФТ-Банк (IBSO) -> Обновления и тестирование Часовой пояс: GMT + 3
На страницу 1, 2, 3, 4, 5  След.
Страница 1 из 5

 
Перейти:  
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете голосовать в опросах
Рейтинг@Mail.ru